Aug 222016
 

DR-BT22 블루투쓰 헤드셋을 우분투에 물려 쓰려고 블루투쓰 usb아답터를 구매해서 사용하기 시작했다. 그런데 자동연결은 되는데, 소리가 헤드셋으로 나오질 않아서 수동으로 전환해야 했다. 찾아보니 다음의 설정을 통해 가능했다.

sudo vi /etc/pulse/default.pa 해서 다음의 라인을 추가
load-module module-switch-on-connect

PulseAudio service 재시작
sudo service pulseaudio restart

이제 헤드셋을 켜고, 플레이버튼만 누르면 자동 연결 후 사운드 장치 전환도 한번에 된다.

Aug 082016
 

엄마가 좋아, 아빠가 좋아?
본격적으로 “말”을 시작한지 얼마 되지 않았는데, 최근 2달 동안의 변화가 엄청나다. 간간히 말을 따라하거나, 기억했다가 나열하다가, 요즘은 복수의 문장을 이어쓰기까지 했다.이런 질문에 보통은, 뒤쪽의 선택사항을 말하는 게 보통이라고 알고 있었지만(짧은 기억력으로 뒤쪽 선택사항만 기억), 한나는 예상과는 다르게 대답해왔다. 질문 순서를 바꿔봐도, 처음에는 항상 “엄마” 먼저 말하고 “아빠” 그리고 “둘 다”라고 한다. 전략적인 선택을 하는 건가 싶다.

오빠가 좋아, 아빠가 좋아?
몇일 전, 와이프가 한나를 데리러 갔다가, 한나가 유치원의 다른 남자 아이 근처에 있는 걸 봤다고 했다. 한나에게 재미삼아 물어봤다. “오빠가 좋아? 아빠가 좋아?”라고 물었더니, 충격적인 대답이 돌아왔다. “오빠 좋아, 아빠 좋아, 둘 다 좋아”. 허걱 싶었다. 2번을 더 물어도 같은 대답이었다. 그날 밤 재워주러 가서 한나를 안고 있었는데, 한나가 뭐라고 나에게 속삭였다. “오빠 좋아, 아빠 미안”. 그 순간 뭐라할 수 없는 감정이 북받쳐왔다.  이제 감정을 이해하고, 그에 걸맞는 말을 함으로써, 감정의 교류도 가능해진듯 싶었다.

아빠의 과일
어제 저녁, 식사를 하고 한나를 씻긴 후 고양이 밥 주러 갔다 오니 한나가 과일 먹으라며 내 손을 잡아 끌었다. 싱크대에 올려져있는 작은 그릇에 담긴 오렌지를 들었더니 자기 주라길래 주었다. 그랬더니 그 안에 담긴 오렌지를 자기 그릇에 다 쏟아부었다. 자기 꺼 다 먹고도 더 먹고 싶었다 보다 싶었다. 오렌지를 몇 개 포크로 찍어 먹었는데, 줄어드는 오렌지 조각들을 보더니, 짜증을 내며 그릇을 자기 쪽으로 감추는 거였다. 안 그래도 요즈음 약간의 식탐이 있기는 했지만, 그동안 잘 교육시켜온 “니 것, 내 것, 남의 것”에 어긋하는 행동이라서, 한동안 토라진 반응을 보여주었다. 결국 나중에 엄마가 시킨 사과를 하긴 했다. 역시 그 날 밤,  밤에 재우러 가서 침대에 내려놓았는데, 그 일에 대해 한나가 사과를 했다. 아빠 과일 쏟아서 먹다가 짜증내서 미안하다는 거였다. 3 문장이 이어진 긴 사과문이었다.

생각하는 의자
27개월차부터 쓰기로 한 생각하는 의자를 처음 써봤다. 목욕하고 기저귀 채우고 로션 바르고, 옷 입히고 머리 말리고 등등의 일에 대해서는 최대한 한나가 협조해주도록 교육을 해왔었다. 매일 반복되는 일에 대해서 다르게 접근하기 위해서였는데, 오랜만에 한나가 비협조적으로 행동했다. 식탁 의자를 아무것도 없는 벽 앞에 옮겨 놓고, 아빠가 돌아올 때까지 의자에 앉아서 무엇을 잘못했는지 생각해보라고 하고, 안 보이는 곳에서 조용히 지켜보았다. 예상처럼, 1분동안은 가만히 앉아있었다가, 1분 정도 후에는 옆쪽으로 틀긴 해도 잘 앉아있었다. 그러다가 실수로 의자에서 떨어져서 살짝 얼굴을 바닥에 부딪힌듯 했다. 근데 놀랍게도 그러자마자 바로 의자로 다시 올라가서 앉는 거였다. 그제서야 엄마, 아빠를 찾으며 낮은 소리로 울기 시작하기에 생각하는 의자 벌을 중지했다. 그날 밤 재우러 갔더니, 의자에 앉아있다가 떨어져서 코가 아팠는데 다시 올라가서 앉아 있었다고 나에게 설명했다.

7PM ~ 7AM
정말 뉴질랜드에 사는 한인 부모 중에 아이를 저녁 7시에 재우는 사람이 없는 걸까? 최근에 와이프가 알게 된 키위 남편과 사는 3자녀의 엄마가 그랬다고 한다. 저녁 8시에 재우면 8시 30분~9시 사이에 잠든 후 6시나 7시 이후에 깨는 패턴을 한 동안 유지하다가, 9시가 잠드는 날이면, 저녁 자유 시간이 너무 짧다는 생각에, 7시 30분에 재우다가, Day Light Saving이 왔다 갔다 하길래, 그냥 7시에 재우기 시작한 게 몇 달 된듯 하다. 7시에 재우러 들어가면 요즘은 15~30분이며 잠이 드는데, 보통은 다음 날 7시 이후로 깬다. 자기 전에는 항상 같은 동화책을 읽는 데 요즘은 애착인형들에게 한나가 그 동화책을 읽어준다. ㅋㅋㅋ 어찌나 귀여운지…

애착인형
누군가가 선물해준, 작은 분홍 곰인형이 No.1 애착인형이다. 두번째는 역시 누군가 선물한 자기 키만한 토끼인형이다. 일부러 강한 애착이 생기지 않게 많은 후보 인형들을 제공하고 골고루 가지고 놀게 했는데, 그 중에 간택당한 녀석들이다. 기저귀 입히고, 분유 먹이고, 책 읽어주고, 같이 자고 등등 많은 것들을 같이 하지만, 놀러갈 때 가지고 갈 정도로 강한 애착은 아니다. 그래도 혹시나 해서 No.1 애착인형은 여분으로 하나 더 구해놓긴 했다.

낮잠
낮잠은 그동안 엄마랑 같이 잤었는데, 한나 침대에 재우기 시작한 지 얼마 되지 않아, 요즘은 졸려할 때에(짜증이 많아지는 시점, 보통 12시~3시 사이) 침대에 넣고 손 잡고 머리 만져주면 3~5분만에 잠이 든다.

목욕
목욕은 저녁 먹고 엄마랑 한동안 하다가, 둘째 소식이 들리고 나서는 나(아빠)와 하기 시작했는데, 처음엔 (목욕하는 순서가 바뀌었으니까) 티격태격하다가 요즘은 그럭저럭 잘 해주고 있다. 옷 벗기(양말/바지는 혼자 벗음) –> 목욕 –> 로션 바르기 –> 기저귀 –> 옷(양말/바지는 역시 혼자 입음) –> 머리 말리기 –> 머리 빗고 머리 핀 하기 등의 긴 일들은 그럭저럭 잘해내고 있다.

Pre-school
월/금은 8시간, 수요일은 오후 4시간 Pre-school에 보내고 있는데, 처음엔 싸준 도시락도 안 먹고 하다가, 요즘은 점심 도시락도 다 먹고 온다. 아마 좀 편안해진듯 싶다. 집에서 가르친, 장난감 갖고 놀고 정리하기, 더러운 거 치우고 닦기 등을 Pre-school에서도 그대로 하고 있어서 선생님들은 실제로 도움이 된다고 한다고 했다. 치우고 정리하고 닦고, 다른 아이들 침도 닦아준다고, 와이프는 좀 걱정이 되는듯 싶은데, 가르친 걸 그대로 잘 하는 걸 나무랄 수는 없기에 그냥 지켜볼 수 밖에 없을 듯 하다. 집에 올 때는 선생님들한테 모두 뽀뽀하는 걸 보니, 적극적 사교성은 와이프에게서 확실히 물려받은 듯 싶다.

Aug 032016
 

와이프가 쓰는 HTC Desire 820이 최근 여러 이상 증세를 보였다. 배터리가 만충이 되지 않아서 배터리 Calibration reset(전원 끈 상태에서 만충 후 부팅 –> 100% 될 때가지 충전 반복) 후 괜찮아 진듯 했는데, 최근 몇일동안에는 분명 HSDPA에 접속이 되기는 하는데, 웹페이지 다운로드가 되지 않는 거였다. 이통사 웹페이지에서 데이타 사용내역을 보니 몇 메가가 잡혀 있었다. 접속 시도 등이 누적된 듯 했다. 접속 방식을 바꾸고 APN 리셋 등의 여러 조치를 해봤지만 딱히 바뀌는 건 없었다. 공장초기화가 생각났다.

관련된 글들을 찾다보니 공장초기화 이전에 캐쉬 파티션을 삭제해보는 게 좋을 듯 싶었다. 개인 데이타를 전혀 건들이지 않고 시스템이 사용하는 캐쉬영역만 날리는 거였다. 현재 안드로이드 4.4.4라서 다음의 글을 보고 해보니 접속 문제가 바로 해결되었다. 아~ 내 아까운 몇 시간이여.

How to wipe Cache Partition on HTC One M7 with Lollipop

 

 

Jul 292016
 

정말 오랜만에 헤드셋을 꺼내어 충전을 해봤다. 2시간여를 충전한 후 넥서스4와 페어링을 해보니 바로 페어링이 된다. 음악 플레이도 잘 되고… 원래 일하는 중엔 음악을 안 듣는 편인데, 영어 공부겸 해서 가벼운 일을 할 때는 뉴스 라디오를 들어보려고 하는 중이었다. 근데, 유선 이어폰은 아무래도 선이 걸리적 거렸다. 문득 이 녀석 생각이 났다. 차고 수납장에 쳐박혀 있던 상자에서 몇년을 잠들어 있었는데도 불구하고 바로 살아났다. 2010년 이전에 구매한 거 같은데, 아직도 배터리가 살아있는 게 신기하다. 배터리 수명이 다 되었다면, 배터리만 구해서 바꿔줘서 계속 사용해야겠다. 사용법을 다 까먹어서 사용자 매뉴얼을 다운로드한 김에 블로그에 백업할겸 겸사겸사 글 한자락을 남겨본다. PDA폰하고 같이 사용하던 녀석을 안드로이드폰하도도 사용하게 될 줄은 몰랐다.

DR-BT22 사용자 매뉴얼

May 192016
 

kk-sp3

 

 

 

 

 

 

공장초기화
전원을 넣고 20초 정도를 기다린 후 전면부 구석에 있는 스위치를 5초 이상 누른 후 손을 떼면 청색 LED가 켜진 상태로 있다가 공장초기화 후 재부팅 된다.

adhoc 모드로 기기에 연결
OK_SP3라는 SSID에 pc를 연결하면 된다.

ssh 접속
192.168.10.253로 ssh 접속(id: root, pw:p9z34c)
만약 이전에 다른 스위치로 이미 접속한 적이 있다면 host identification이 바뀌었다며 접속이 되지 않을 것이다. 이런 경우는 ~/.ssh/known_hosts를 지우면 된다. 윈도우의 경우라면…흠…잘 모르겠다.

펌웨어 버전
cat /etc/online.txt하면 VerInfo SW_VER3.4 HW_VER1.2 (null) (null) (null) (null)같이 출력된다. 펌웨어는 3.4(현재 3.5까지 나와있으나 구글커뮤니티를 보면 무슨 문제가 있는지 3.3으로 다운그레이드를 하는 듯 하다.)이고 하드웨어는 1.2이다. 별 다른 업그레이드 필요를 느끼지 못해서 그냥 넘어가지만 추후를 대비해서 펌웨어 업그레이드 방법을 남겨둔다.
cd /tmp (tmp가 가장 여유용량이 많다);
wget 펌웨어_다운로드_url(https는 안됨);
sysupgrade -c 펌웨어파일명;

password 변경
보안을 위해 passwd 실행 후 원하는 암호로 변경한다.

네트워크 설정
(1) WIFI 설정
사용중인 무선랜에 접속하도록 SSID와 암호 등을 설정해준다. http://www.cisco.com/c/en/us/td/docs/wireless/wcs/3-2/configuration/guide/wcscfg32/wcscod.html를 참조해서 Wifi country code를 골라서 설정해주면 좋다.
vi /etc/config/wireless
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option path ‘platform/ar933x_wmac’
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
option country ‘NZ’

config wifi-iface
option device radio0
option network wwan
option mode sta
option ssid ‘YourWIFISSID’
option key ‘PasswordToYourWIFISSID’
option encryption psk

(2) 네트워크 설정
무선랜 설정에서 지정한 wwan에 대한 항목을 추가해준다. 일단 DHCP로 IP를 받아오게 한 후, 인터넷 라우터에서 고정할당을 해주고, static으로 변경하여 고정된 ip를 사용하게 할 예정이다.
vi /etc/config/network
config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fdab:ee91:1053::/48’

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.10.253’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘wwan’
option proto ‘dhcp’

변경을 마치고 reboot 명령어로 리부팅한 후 라우터로 가서 새로 등록된 DHCP 기기를 확인 후 IP고정할당을 해주면 된다.

 

NTP 설정과 시작시 Power on
여기를 참조해서 /etc/config/system파일과 /etc/TZ을 다음과 같이 수정 후 ntp 클라이언트를 실행(/etc/init.d/sysntpd enable; /etc/init.d/sysntpd start)해서 장치의 시간이 정확히 업데이트되고 부팅 직후 Relay를 on으로 만들 수 있었다.
vi /etc/config/system
config system
option hostname ‘MySwitch2’
option zonename ‘Pacific/Auckland’
option timezone ‘NZST-12NZDT,M9.5.0,M4.1.0/3’
option conloglevel ‘8’
option cronloglevel ‘8’

config timeserver ‘ntp’
list server ‘0.openwrt.pool.ntp.org
list server ‘1.openwrt.pool.ntp.org
list server ‘2.openwrt.pool.ntp.org
list server ‘3.openwrt.pool.ntp.org
option enable_server ‘0’

config restorefactory
option button ‘reset’
option action ‘pressed’
option timeout ‘2’

config led
option name ‘flashing’
option sysfs ‘tp-link:blue:config’
option trigger ‘none’
option default ‘1’

config led
option name ‘Relay’
option sysfs ‘tp-link:blue:relay’
option trigger ‘none’
option default ‘1’

이후 다음을 실행해서 데몬을 실행시키면 됨
/etc/init.d/sysntpd enable
/etc/init.d/sysntpd start

HTTP 서버
놀랍게도 이 작은 녀석이 http 서버 역할도 한다. 부팅 후 기본적으로 서버가 동작하는 데 document root는 /www이다. 보안상 디렉토리 구조를 보여주지 않는 것이 좋기도 하고, 추후 /www에 설정 파일을 생성할 예정이므로 index.html을 생성해 두기로 한다.
vi /www/index.html
<html><head>MySwitch</head><body>My Switch Control</body></html>
pc에서 웹브라우저를 열고 장치의 ip로 접근해보면 생성한 index.html이 열리는 걸 볼 수 있다.

opkg 설치 및 패키지 목록 업데이트
opkg는 ipkg의 fork 프로젝트인데 embedded linux용 패키지 관리자다. 추후 curl 설치를 위해 설치가 필요한데, 장치에서 바로 다운로드 후 설치하면 된다.
cd /root
wget https://madforfamily.com/wp-content/uploads/2016/05/opkg-rc3.tar.gz
tar xz -C / -f /root/opkg-rc3.tar.gz
opkg update (시간이 좀 걸린다)
rm opkg-rc3.tar.gz (공간 절약을 위해 설치파일 삭제)

<Update> HTTPS 적용으로 인해 위의 wget이용한 다운로드가 불가능하다(설치된 wget는 https 지원안함). 따라서 해당 파일을 로컬 pc에 다운로드 후 scp 등을 통해 장치로 copy해넣어야 한다.

« 1 2 3 4 5 6 7 8 9 10 11 12 ... 65 »