Aug 032016
 

와이프가 쓰는 HTC Desire 820이 최근 여러 이상 증세를 보였다. 배터리가 만충이 되지 않아서 배터리 Calibration reset(전원 끈 상태에서 만충 후 부팅 –> 100% 될 때가지 충전 반복) 후 괜찮아 진듯 했는데, 최근 몇일동안에는 분명 HSDPA에 접속이 되기는 하는데, 웹페이지 다운로드가 되지 않는 거였다. 이통사 웹페이지에서 데이타 사용내역을 보니 몇 메가가 잡혀 있었다. 접속 시도 등이 누적된 듯 했다. 접속 방식을 바꾸고 APN 리셋 등의 여러 조치를 해봤지만 딱히 바뀌는 건 없었다. 공장초기화가 생각났다.

관련된 글들을 찾다보니 공장초기화 이전에 캐쉬 파티션을 삭제해보는 게 좋을 듯 싶었다. 개인 데이타를 전혀 건들이지 않고 시스템이 사용하는 캐쉬영역만 날리는 거였다. 현재 안드로이드 4.4.4라서 다음의 글을 보고 해보니 접속 문제가 바로 해결되었다. 아~ 내 아까운 몇 시간이여.

How to wipe Cache Partition on HTC One M7 with Lollipop

 

 

Jul 292016
 

정말 오랜만에 헤드셋을 꺼내어 충전을 해봤다. 2시간여를 충전한 후 넥서스4와 페어링을 해보니 바로 페어링이 된다. 음악 플레이도 잘 되고… 원래 일하는 중엔 음악을 안 듣는 편인데, 영어 공부겸 해서 가벼운 일을 할 때는 뉴스 라디오를 들어보려고 하는 중이었다. 근데, 유선 이어폰은 아무래도 선이 걸리적 거렸다. 문득 이 녀석 생각이 났다. 차고 수납장에 쳐박혀 있던 상자에서 몇년을 잠들어 있었는데도 불구하고 바로 살아났다. 2010년 이전에 구매한 거 같은데, 아직도 배터리가 살아있는 게 신기하다. 배터리 수명이 다 되었다면, 배터리만 구해서 바꿔줘서 계속 사용해야겠다. 사용법을 다 까먹어서 사용자 매뉴얼을 다운로드한 김에 블로그에 백업할겸 겸사겸사 글 한자락을 남겨본다. PDA폰하고 같이 사용하던 녀석을 안드로이드폰하도도 사용하게 될 줄은 몰랐다.

DR-BT22 사용자 매뉴얼

May 192016
 

kk-sp3

 

 

 

 

 

 

공장초기화
전원을 넣고 20초 정도를 기다린 후 전면부 구석에 있는 스위치를 5초 이상 누른 후 손을 떼면 청색 LED가 켜진 상태로 있다가 공장초기화 후 재부팅 된다.

adhoc 모드로 기기에 연결
OK_SP3라는 SSID에 pc를 연결하면 된다.

ssh 접속
192.168.10.253로 ssh 접속(id: root, pw:p9z34c)
만약 이전에 다른 스위치로 이미 접속한 적이 있다면 host identification이 바뀌었다며 접속이 되지 않을 것이다. 이런 경우는 ~/.ssh/known_hosts를 지우면 된다. 윈도우의 경우라면…흠…잘 모르겠다.

펌웨어 버전
cat /etc/online.txt하면 VerInfo SW_VER3.4 HW_VER1.2 (null) (null) (null) (null)같이 출력된다. 펌웨어는 3.4(현재 3.5까지 나와있으나 구글커뮤니티를 보면 무슨 문제가 있는지 3.3으로 다운그레이드를 하는 듯 하다.)이고 하드웨어는 1.2이다. 별 다른 업그레이드 필요를 느끼지 못해서 그냥 넘어가지만 추후를 대비해서 펌웨어 업그레이드 방법을 남겨둔다.
cd /tmp (tmp가 가장 여유용량이 많다);
wget 펌웨어_다운로드_url(https는 안됨);
sysupgrade -c 펌웨어파일명;

password 변경
보안을 위해 passwd 실행 후 원하는 암호로 변경한다.

네트워크 설정
(1) WIFI 설정
사용중인 무선랜에 접속하도록 SSID와 암호 등을 설정해준다. http://www.cisco.com/c/en/us/td/docs/wireless/wcs/3-2/configuration/guide/wcscfg32/wcscod.html를 참조해서 Wifi country code를 골라서 설정해주면 좋다.
vi /etc/config/wireless
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option path ‘platform/ar933x_wmac’
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
option country ‘NZ’

config wifi-iface
option device radio0
option network wwan
option mode sta
option ssid ‘YourWIFISSID’
option key ‘PasswordToYourWIFISSID’
option encryption psk

(2) 네트워크 설정
무선랜 설정에서 지정한 wwan에 대한 항목을 추가해준다. 일단 DHCP로 IP를 받아오게 한 후, 인터넷 라우터에서 고정할당을 해주고, static으로 변경하여 고정된 ip를 사용하게 할 예정이다.
vi /etc/config/network
config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fdab:ee91:1053::/48’

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.10.253’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘wwan’
option proto ‘dhcp’

변경을 마치고 reboot 명령어로 리부팅한 후 라우터로 가서 새로 등록된 DHCP 기기를 확인 후 IP고정할당을 해주면 된다.

 

NTP 설정과 시작시 Power on
여기를 참조해서 /etc/config/system파일과 /etc/TZ을 다음과 같이 수정 후 ntp 클라이언트를 실행(/etc/init.d/sysntpd enable; /etc/init.d/sysntpd start)해서 장치의 시간이 정확히 업데이트되고 부팅 직후 Relay를 on으로 만들 수 있었다.
vi /etc/config/system
config system
option hostname ‘MySwitch2’
option zonename ‘Pacific/Auckland’
option timezone ‘NZST-12NZDT,M9.5.0,M4.1.0/3’
option conloglevel ‘8’
option cronloglevel ‘8’

config timeserver ‘ntp’
list server ‘0.openwrt.pool.ntp.org
list server ‘1.openwrt.pool.ntp.org
list server ‘2.openwrt.pool.ntp.org
list server ‘3.openwrt.pool.ntp.org
option enable_server ‘0’

config restorefactory
option button ‘reset’
option action ‘pressed’
option timeout ‘2’

config led
option name ‘flashing’
option sysfs ‘tp-link:blue:config’
option trigger ‘none’
option default ‘1’

config led
option name ‘Relay’
option sysfs ‘tp-link:blue:relay’
option trigger ‘none’
option default ‘1’

이후 다음을 실행해서 데몬을 실행시키면 됨
/etc/init.d/sysntpd enable
/etc/init.d/sysntpd start

HTTP 서버
놀랍게도 이 작은 녀석이 http 서버 역할도 한다. 부팅 후 기본적으로 서버가 동작하는 데 document root는 /www이다. 보안상 디렉토리 구조를 보여주지 않는 것이 좋기도 하고, 추후 /www에 설정 파일을 생성할 예정이므로 index.html을 생성해 두기로 한다.
vi /www/index.html
<html><head>MySwitch</head><body>My Switch Control</body></html>
pc에서 웹브라우저를 열고 장치의 ip로 접근해보면 생성한 index.html이 열리는 걸 볼 수 있다.

opkg 설치 및 패키지 목록 업데이트
opkg는 ipkg의 fork 프로젝트인데 embedded linux용 패키지 관리자다. 추후 curl 설치를 위해 설치가 필요한데, 장치에서 바로 다운로드 후 설치하면 된다.
cd /root
wget https://madforfamily.com/wp-content/uploads/2016/05/opkg-rc3.tar.gz
tar xz -C / -f /root/opkg-rc3.tar.gz
opkg update (시간이 좀 걸린다)
rm opkg-rc3.tar.gz (공간 절약을 위해 설치파일 삭제)

<Update> HTTPS 적용으로 인해 위의 wget이용한 다운로드가 불가능하다(설치된 wget는 https 지원안함). 따라서 해당 파일을 로컬 pc에 다운로드 후 scp 등을 통해 장치로 copy해넣어야 한다.

May 032016
 

식구가 하나 늘었다. 지난 토요일에 데리고 온 아기 고양이 Gray다. 대략 생후 5~8주로 추정되는, 얼뜻 보면 곰을 닮은 고양이다. 사람 따라 졸졸 따라다니게 전형적인 “개냥이”과인듯 하다.

데리고 온 첫 날, 놀아주다가 저녁에 되어 차고에 마련해둔 보금자리에 두었더니 엄청 울어댔다. 새벽에도 몇번 울어대는 통에 내가 잠을 다 못 잤다. 두번 째 날은 신기하게도 한창을 울어대다가 한나 재우고 나서는 한번도 울지 않았다. 그 이후로도 계속 잘 자는 듯 했다. 열심히 놀아주고, 때 되면 불 끄고 아무 소리가 안 나니 우리 따라 자는 거 같다.

무엇보다 한나가 너무 좋아한다. 요즘 친해진 한인 부부네에게서 얻어온 녀석인데, 동물과 친해지는 것이 아이의 감정 발달에 도움이 될 것을 기대하면서 데려왔다. 그래도 새 식구 들이기가 만만치는 않다. 이미 구입한 용품도 많지만, 앞으로도 몇 가지 장난감이랑 용품은 좀 사둬야 할 거 같다. 사료랑 모래 말고도, 어릴 때는 건강 관리도 신경써줘야 하고…

같이 사는 존재가 하나 늘었지만 그래도 내가 사랑하는 두 사람 – 와이프와 한나가 좋아하니 너무 좋다. 그래도 관리하는 품을 줄여주는 것들을 조금씩 미리 찾아둬야 하겠기에 처음으로 Aliexpress에서 몇가지를 주문했다. 언제쯤 도착할런지…

Apr 182016
 

오후에 퇴근해보니 집에 아무도 없어서 와이프에게 문자를 보냈더니 타운 근처의 클리닉에 있다고 해서 급히 나갔다. 들어보니 한나가 콧물+기침+열로 아프다가 열성 경련이 3번째 와서 병원에 왔다는 거였다. 역시 별달리 해주는 건 없었고, 다시 경련이 오면 Middlemore 병원으로 가라는 얘기만 들을 수 있었다. 금요일 병가를 내고 같이 지냈는데, 낮잠 자고 일어나서 한나가 다시 경련을 했다. 이번에는 약 30초 이상이었다. 와이프가 첫 경련을 봤을 때의 그 느낌을 나도 고스란히 받을 수 있었다. 병원에 가봐야 해주는 게 없다는 걸 알고 있지만 그냥 있을수만도 없었다. 짐을 챙겨서 병원으로 갔다. 컨디션이 안 좋은 한나는 체온/혈압/심전도 등의 기본검사에도 울면서 힘들어했다.  요로감염 점검을 위해 수집 bag을 채웠는데 소변이 채워진 걸 확인하고 staff 호출벨을 눌렀지만 아무도 오지 않아 설사로 인해 오염이 되어 다시 채집해야 했다. 그러는 와중 몇 시간만에 볼 수 있었던 의사는, “정상적인 열성경련”이며 열만 잘 케어해주면 된다고 했다.

요로감염 검사 결과를 알고 싶어서 다시 소변채집을 시도했는데 겨우 성공해서 결과를 기다렸다. 30분이 넘어도 아무 연락이 없다가, “기계가 고장”나서 오래 걸렸다며, 의사의 확인하에 간단 검사라도 하고 알려준다고 했다. 결과는 정상. 하지만 퇴원을 위해 의사의 확인이 필요하다고 해서 기다렸는데, 한 시간 넘게 아무 진척이 없었다. 간호사도 안 보이고 의사도 안 보이고…겨우 간호사를 찾았더니 의사에게 3번이나 얘기했다고 했다. 마침 자리로 돌아온 의사를 찾아가니 그제서야 퇴원해도 된다고 했다. 참 편하게들 일한다 싶었다.

집으로 돌아와서 한나는 바로 곯아 떨어졌고 다음 날 아침 여느때처럼 일어났다. 컨디션도 좋고 열도 오르지 않아서 해열제도 필요없었다. 다만 콧물과 간헐적인 기침만 남았는데, 이와 동시에 내가 콧물/재채기가 시작되었다.

부모가 된다는 거, 그건… 생각보다 어렵다.

« 1 2 3 4 5 6 7 8 9 10 11 12 ... 66 »